0
   

Twin Alternating Water Softener Favours One Bed Only

 
 
Jondc90
 
Reply Fri 6 Dec, 2019 09:16 am
I have a twin 298 Magnum IT water softener with Logix 764 controller that is designed for continuous twin alternating operation.

The problem I have with the unit is that it always favours one of the two beds - it only runs on bed #2.

When the throughput on bed #2 has reached zero, the softener will automatically initiate a regeneration (as it should), and for the regeneration of bed #2, it will switch to bed #1; However, as soon as the regeneration is complete, the unit immediately switches over to bed #2 again. The softener does not allow bed #1 to run for any duration of time longer than what it takes for bed #2 to complete its regeneration.

This is a major efficiency issue as softener bed #1 is never allowed to be run for the full duration of its throughput.

I have read the manual and checked the programming on the softener. It is programmed to "298A" which i believe should be the correct setting for the unit: "Twin Alternating, 5-cycle conditioner, with 2" inlet". Is there some other setting somewhere that needs to changed to allow bed #1 to operate?

We have had several water softener experts come and look at the unit as well but none of them have been able to solve the problem. One of these contractors has recently replaced the communication cable between the two softener heads but that did not solve the problem.

Any experts on Magnum IT softeners or Logix controllers that think they might know the solution?

Thanks in advance!
  • Topic Stats
  • Top Replies
  • Link to this Topic
Type: Question • Score: 0 • Views: 361 • Replies: 0
No top replies

 
 

Related Topics

 
  1. Forums
  2. » Twin Alternating Water Softener Favours One Bed Only
Copyright © 2020 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.03 seconds on 01/27/2020 at 10:20:13