1
   

Virtual Hosting roadblock... (Server 2003 WAMP)

 
 
mrcolj
 
Reply Tue 20 Dec, 2005 05:53 pm
I've been trying to learn to set up a WAMP server in my house, and I'm pretty darn close. I've run a site for years, but am new to servers and hosting. I got my httpd.conf and php.ini files and mysql all working (somewhat), and the programs that need mysql separated from the programs that need mysqli. Problem, however:

I just can't get virtual hosting right. The <virtual hosting> directives in httpd.conf seem to work at all, and it must be a really simple thing I'm overlooking, but I've been stuck for weeks. When I go to mysite.com, it just goes to the root localhost index.php (the one that says "if you can see this, apache is set up correctly.) I've skinned my <virtual host> directive pretty far down, excluding serveradmin and includes until I get the basics down, but I'm still stuck.

Will someone please help me troubleshoot? or tell me what the basic thing is I'm doing wrong?

This is what I have:
Code:NameVirtualHost *:80

<VirtualHost *>
ServerName localhost
DocumentRoot "E:/Docume~1/Administrator/MyDocu~1/Websites/"
</VirtualHost>

<VirtualHost *>
ServerName www.site1.com
ServerAlias site1.com *.site1.com
DocumentRoot "E:/Docume~1/Administrator/MyDocu~1/Websites/www.site1.com"
</VirtualHost>

<VirtualHost *>
ServerName www.site2.com
ServerAlias site2.com *.site2.com
DocumentRoot "E:/Docume~1/Administrator/MyDocu~1/Websites/www.site2.com"
</VirtualHost>

<VirtualHost *>
ServerName www.site3.com
ServerAlias site3.com *.site3.com
DocumentRoot "E:/Docume~1/Administrator/MyDocu~1/Websites/www.site3.com"
</VirtualHost>

<VirtualHost *>
ServerName www.site4.com
ServerAlias site4.com *.site4.com
DocumentRoot "E:/Docume~1/Administrator/MyDocu~1/Websites/www.site4.com"
</VirtualHost>

<VirtualHost *>
ServerName www.site5.org
ServerAlias site5.org *.site5.org
DocumentRoot "E:/Docume~1/Administrator/MyDocu~1/Websites/www.site5.org"
</VirtualHost>

<VirtualHost *>
ServerName www.site6.com
ServerAlias site6.com *.site6.com
DocumentRoot "E:/Documents and Settings/Administrator/My Documents/Websites/www.site6.com"
</VirtualHost>

<VirtualHost *>
ServerName www.site7.com
ServerAlias site7.com *.site7.com
DocumentRoot "E:/Docume~1/Administrator/MyDocu~1/Websites/www.site7.com"
</VirtualHost>
  • Topic Stats
  • Top Replies
  • Link to this Topic
Type: Discussion • Score: 1 • Views: 1,020 • Replies: 1
No top replies

 
Craven de Kere
 
  1  
Reply Wed 28 Dec, 2005 12:47 am
I don't have time to trouble-shoot your conf file but here's an example that you can try:

Code:
<VirtualHost 55.55.55.555>
ServerAlias www.domain.com domain.com
ServerAdmin [email protected]
DocumentRoot /home/domain/public_html
BytesLog domlogs/domain.com-bytes_log
ServerName www.domain.com
User survey
Group survey
CustomLog domlogs/domain.com combined
ScriptAlias /cgi-bin/ /home/domain/public_html/cgi-bin/
</VirtualHost>
0 Replies
 
 

Related Topics

In How much time a website can be developed? - Question by aussiejumpingcastle
Webdevelopment and hosting - Question by harisit2005
Showing an Ico File - Discussion by Brandon9000
how to earn money in internet - Discussion by rizwanaraj
The version 10 bug. Worse then Y2K! - Discussion by Nick Ashley
CSS Border style colors - Question by meesa
There is no Wisdom in Crowds - Discussion by ebrown p
THANK YOU CRAVEN AND NICK!!! - Discussion by dagmaraka
I'm the developer - Discussion by Nick Ashley
 
  1. Forums
  2. » Virtual Hosting roadblock... (Server 2003 WAMP)
Copyright © 2022 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.03 seconds on 10/06/2022 at 06:05:34