0
   

Can't Join Private Facebook Groups Despite Admin Invites – Tried Common Fixes

 
 
Mariuk
 
Reply Wed 6 Dec, 2023 03:27 am
Hi everyone,

I'm facing a persistent issue on Facebook where I'm unable to join private groups despite being invited by the admins. The "Join Group" button is missing on my MacBook and greyed out on my Huawei P10 phone, across all browsers (Opera, Chrome, Safari). (I can join public groups without any issues)

Steps I've already tried:

- Cleared browser cache/cookies.
- Updated the Facebook app.
- Checked for account restrictions – none found.
- Reviewed Facebook Community Standards.
- Contacted group admins – they confirmed no barriers on their end.
- Uninstalled antivirus software and disabled VPN.
- Reached out to Facebook support multiple times with no response.
- I'm not at group joining limit and haven't recently joined lots of groups or carried out any unusual activity in the account.
- I am trying to join with my account/profile NOT a Page.

This has been an issue for several weeks, and my account is over 10 years old with no previous problems. If anyone has experienced something similar or has any insights, your help would be greatly appreciated.

Thank you!
Mari
  • Topic Stats
  • Top Replies
  • Link to this Topic
Type: Question • Score: 0 • Views: 928 • Replies: 0
No top replies

 
 

Related Topics

Blue screen of Death - Question by dagmaraka
Transfering Bubbled Data to Web - Question by act180
DVD problem - Discussion by bible quizzer
Mac Remote Control - Question by Shapeless
 
  1. Forums
  2. » Can't Join Private Facebook Groups Despite Admin Invites – Tried Common Fixes
Copyright © 2024 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.03 seconds on 02/23/2024 at 06:31:15