2
   

restored database has no username prefix

 
 
Reply Thu 24 Jun, 2004 03:58 am
Hi there, I hope I can find help here.
I tried phpbb.com but there wasnt any good.

I have changed web hosting company.
The database which i want to restore, has no username prefix at front of database name.
but, every database created in my new web hosting, has a prefix at the front generated.

When i restored the database, i am unable to do anything from there coz the database names are both different.

Things that i have tried:
1- ask web hosting company to override the prefix, but unsuccessful
2- modify the backup database to add in the prefix all over
3- flush cache n temp files

Any suggestion to get around the prefix?
  • Topic Stats
  • Top Replies
  • Link to this Topic
Type: Discussion • Score: 2 • Views: 1,364 • Replies: 5
No top replies

 
nookie123
 
  1  
Reply Thu 24 Jun, 2004 07:19 am
ok. i have also tried adding a prefix to the backuped database name. and made changes to config.php

then i drop database, and installed phpBB again.
replaced config.php.
restored modified database

everything looks fine in acp but when i clicked on "preview forum" "forum index " or "mass email", theres an error page generated.
0 Replies
 
Craven de Kere
 
  1  
Reply Thu 24 Jun, 2004 09:28 am
Having a name as a prefix to the database is a host setting. Asking them to change is is unreasonable as it is the way their virtual hosting is set up and there's no reason they should (your problem is easy to solve).

Just change the config file to accurately relect the info and you are set.

Sounds like you did, and the problems you report do not sound like they have anything to do with the database (except prhaps some settings in the configuration options that are stored there.
0 Replies
 
nookie123
 
  1  
Reply Sun 27 Jun, 2004 11:22 pm
Thanks for the feedback. Web hosting did not chnage its web hosting setup and i ran out of ideas on how to go abt it. Reinstalled a new phpbb instead :-)
0 Replies
 
Craven de Kere
 
  1  
Reply Mon 28 Jun, 2004 01:04 am
Dude, you can just change the dbname in the config file. That's all it takes.
0 Replies
 
nookie123
 
  1  
Reply Mon 28 Jun, 2004 03:19 am
hi, I tried changing dbname in config file too but it didnt work. its all weird. I suspect that i have messed up the dir structure and hence restore stuffed up.

no worries. :-)

ps. I have installed mod rewrite 1.0.0 and when clicking on a forum in guest mode, i get a 404. any idea where i stuffed up this time? Confused
0 Replies
 
 

Related Topics

In How much time a website can be developed? - Question by aussiejumpingcastle
Webdevelopment and hosting - Question by harisit2005
Showing an Ico File - Discussion by Brandon9000
how to earn money in internet - Discussion by rizwanaraj
The version 10 bug. Worse then Y2K! - Discussion by Nick Ashley
CSS Border style colors - Question by meesa
There is no Wisdom in Crowds - Discussion by ebrown p
THANK YOU CRAVEN AND NICK!!! - Discussion by dagmaraka
I'm the developer - Discussion by Nick Ashley
 
  1. Forums
  2. » restored database has no username prefix
Copyright © 2021 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.03 seconds on 07/28/2021 at 09:12:30