0
   

Rainsoft "Q2" vavle repair question

 
 
Reply Fri 14 Aug, 2009 11:00 pm
I have a Rainsoft AQ32CT water softening system that has given me 12 years of good service. I just noticed that it is not regenerating and was very warm to the touch at the motor site. It has 120V at the input but there is no movement when I try to start a manual regeneration cycle, just shows up as ..error.. Could the valve be stuck and the motor unable to turn it? Which way do the cams rotate looking from the front of unit? Can I manually turn them? Where can I find a repair manual for this unit? Any help would be greatly appreciated.
Thanks, Dennis
  • Topic Stats
  • Top Replies
  • Link to this Topic
Type: Question • Score: 0 • Views: 2,241 • Replies: 3
No top replies

 
Joethewaterguy
 
  1  
Reply Sat 15 Aug, 2009 06:26 am
@Roadrunner818489,
sounds like the orings and shear pin need replaced. when the shear pin breaks,caused by a stuck piston, the drive motor keeps turning and heats up until it burns up. cams rotate counter clockwise , manually turing them wont do any good if the piston is stuck, actually they probably won't turn.
Roadrunner818489
 
  1  
Reply Mon 17 Aug, 2009 09:27 pm
@Joethewaterguy,
How can I free-up the piston?Where are the o-rings located? What about the shear pin? Next question, who do I turn to for replacement parts? Thanks, Dennis
Joethewaterguy
 
  1  
Reply Thu 20 Aug, 2009 10:29 am
@Roadrunner818489,
the orings are on the piston. the shear pin attaches the hex shaft that drives the cams to the round shaft on the drive motor. local rainsoft dealer should sell you the parts..
0 Replies
 
 

Related Topics

 
  1. Forums
  2. » Rainsoft "Q2" vavle repair question
Copyright © 2019 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.04 seconds on 10/15/2019 at 02:59:09