Reply Wed 8 Apr, 2009 06:03 pm
I have a rainsoft unit around 14 years old. The unit times properly and goes through the cycles when you do the two turn regeneration manually. The problem is it does not draw salt from the brine tank and the water is a rust color. MODEL AM24 CONTROLS
ANY IDEAS????
  • Topic Stats
  • Top Replies
  • Link to this Topic
Type: Question • Score: 0 • Views: 2,472 • Replies: 4
No top replies

 
H2O MAN
 
  0  
Reply Thu 9 Apr, 2009 05:15 am
@DAN BEDENBAUGH,
DAN BEDENBAUGH wrote:

I have a rainsoft unit around 14 years old. The unit times properly and goes through the cycles when you do the two turn regeneration manually. The problem is it does not draw salt from the brine tank and the water is a rust color. MODEL AM24 CONTROLS
ANY IDEAS????


Chances are good that all 5 O rings and both shut off tabs need to be replaced.
DAN BEDENBAUGH
 
  1  
Reply Thu 9 Apr, 2009 11:19 am
@H2O MAN,
Where are o rings located and what/where are the tabs ? I did take off the tube running to the brine tank and the cylinder mounted on the back of the control the tube goes into never seems to start suction on the line to salt tank.
H2O MAN
 
  0  
Reply Fri 10 Apr, 2009 08:38 am
@DAN BEDENBAUGH,


All of the items fit inside the brass valve and they all work together.
Request a schematic from RainSoft customer service.
0 Replies
 
Joethewaterguy
 
  1  
Reply Thu 16 Apr, 2009 05:31 pm
@DAN BEDENBAUGH,
it could also be with that much iron that the injector is clogged, and , or the flow dispenser is plugged.
0 Replies
 
 

Related Topics

 
  1. Forums
  2. » RAINSOFT AM24 TIMER
Copyright © 2019 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.03 seconds on 09/16/2019 at 02:47:51