Reply Wed 4 Mar, 2009 07:27 am
My brine tank keeps filling up with water, and flooding the house with salt. How do I solve this problem?
  • Topic Stats
  • Top Replies
  • Link to this Topic
Type: Question • Score: 0 • Views: 4,403 • Replies: 20
No top replies

 
Gary Slusser
 
  2  
Reply Wed 4 Mar, 2009 10:23 am
@2985seminole,
Check the brine line for loose connections and the drain line for kinks/blockages, or the injector or injector screen.
0 Replies
 
Joethewaterguy
 
  1  
Reply Wed 11 Mar, 2009 11:47 am
@2985seminole,
need to know the type of the unit? sound's like it's an AM ** series, with the mechanical timer. If so the timer mech is obsolete. convert to the appropriate TC conversion kit. digital instead of mechanical.
Joe
0 Replies
 
H2O MAN
 
  1  
Reply Wed 11 Mar, 2009 04:15 pm
If it's an old brass valve you probably need to replace the 3 O rings on the piston and the 2 O rings on the brine injector tube.
You may also need to replace both shut off tabs.

Do these things and let me know if it worked.
louiss3000
 
  1  
Reply Sun 28 Jun, 2009 12:33 pm
@H2O MAN,
H2O Man, Sorry to jump in here, you mention 5 o-rings. Can these be obtained from you? I also have an old brass-valve unit that I picked up basically free. It seems to be OK, but will not draw brine. Can you also supply other RS parts, such as the plastic float ball assembly?
0 Replies
 
H2O MAN
 
  1  
Reply Sun 28 Jun, 2009 04:34 pm


Joethewaterguy has claimed that is able to get all sorts of RainSoft parts... I would ask him for help.
louiss3000
 
  1  
Reply Mon 29 Jun, 2009 05:49 pm
@H2O MAN,
If we go back 2 posts, you mentioned 2 o-rings on thr brine injector. I've done all 5, still no joy, will not draw brine. Am I missing something? If you were to guess, where might I look? Possibly a glaring error on my part - from the back, water in on the right, out the center?
Joethewaterguy
 
  1  
Reply Tue 30 Jun, 2009 05:26 am
@louiss3000,
it's backwards, water in the center out from the side
Joethewaterguy
 
  1  
Reply Tue 30 Jun, 2009 05:29 am
@louiss3000,
probably resin clogging everything , could cause no brine draw, salt tank overflow and low water pressure in faucets, toilets, and washer on cold fill
0 Replies
 
H2O MAN
 
  1  
Reply Tue 30 Jun, 2009 07:32 am
@Joethewaterguy,
louiss3000 wrote:

Possibly a glaring error on my part - from the back, water in on the right, out the center?


Joethewaterguy wrote:

it's backwards, water in the center out from the side


+1
0 Replies
 
louiss3000
 
  1  
Reply Tue 30 Jun, 2009 05:04 pm
Joe, H2OGuy,

Thanks for the replies. I did find a reference to the proper direction. Luckily, the unit is not hooked up in the house, I'm using a garden hose for supply, with the output capped off. Cleaning and replacing the 5 o-rings allowed the unit to draw brine. The issue now is with the Triguard valve and the poppet underneath. The valve stays full and water never flows into the brine tank. When I got the unit the middle port was cracked, I drilled and tapped a fitting there, but I'm sure this is not the way. Are these valves available anywhere? Also, looking at the poppet, is there supposed to be a spring to hold it up? It looks like that would solve the ball in the top issue??

Thanks guys for all the help..
LS
H2O MAN
 
  1  
Reply Tue 30 Jun, 2009 05:56 pm
@louiss3000,


There is no spring for the poppet and Joe should be able to track down a replacement Tri-guard for you.
0 Replies
 
Joethewaterguy
 
  1  
Reply Tue 30 Jun, 2009 05:58 pm
@louiss3000,
any local authorized dealer/service provider should be able to sell you the parts.
louiss3000
 
  1  
Reply Tue 30 Jun, 2009 06:21 pm
@Joethewaterguy,
Thank You Joe, but from what I've read Rainsoft dealers won't just sell parts? I'll give it a try tomorrow and see.

Thanks again,
LS
H2O MAN
 
  0  
Reply Tue 30 Jun, 2009 06:37 pm
@louiss3000,


LS, if you have no luck with your local BrainSoft dealer you can try the factory.
http://www.rainsoft.com/customer-service/warranty.cfm
0 Replies
 
Joethewaterguy
 
  1  
Reply Thu 9 Jul, 2009 10:10 pm
@louiss3000,
so what happenned?
louiss3000
 
  1  
Reply Tue 14 Jul, 2009 12:36 pm
@Joethewaterguy,
Well, the Rainsoft Corporate address above never replied. I was expecting at least a call from a local sales guy. Just for laughs, I walked into our local RS location, explained that I needed a new Tri-Guard for my old brass valve unit, and the very friendly and knowledgeable lady promptly walked to the back and got one. $37.50 please. She went on to explain that she had all the other parts in stock except for some timer parts, and to stop back if I needed something else. No sales guys, no pressure, just a friendly, seemingly well trained individual. The unit seems to work fine, it's installed and working.

I do have a setup question though. How do I adjust/set for hardness? What sets the speedof the brine draw? I mean I see the setting for water into the brine tank, it's set at 4, and it takes about 25 minutes to draw it all off. It seems related to the orfice behind the drain line fitting?

Again, thanks for all the help...
LS
H2O MAN
 
  1  
Reply Tue 14 Jul, 2009 12:44 pm
@louiss3000,
Excellent outcome!

louiss3000 wrote:

She went on to explain that she had all the other parts in stock except for some timer parts


Yeah, the index lever is the most important part that was dropped from inventory several years ago.
It's a stamped metal part that should not be that hard to fabricate is someone has the tooling...
0 Replies
 
Joethewaterguy
 
  1  
Reply Wed 15 Jul, 2009 05:59 am
@louiss3000,
glad that it worked out for you. the hardness is set by the amount of time on the salt setting. If you're not running out of soft water between regen's, there is no reason to touch it. 25 minutes seems about right for the brine draw. don't touch the size of the "orifice" behind the drain fitting. It's sized to give the proper flow for backwash. Too big of a hole in it and it will start backwashing the resin right down the drain. Joe
0 Replies
 
Barbara007
 
  1  
Reply Mon 4 Jan, 2010 08:32 pm
I have a gold series rainsoft and need an owner's operational manual. my brine tank is filling to the top. The tank has not overflowed yet! I cleaned it out and added more salt to see if it was clogged! Any other suggestions? send manual to nameonetwo @hotmail.com

 

Related Topics

 
  1. Forums
  2. » Rainsoft problem
Copyright © 2021 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.03 seconds on 10/22/2021 at 07:59:25