Member since February 17, 2011

dtaylor81

My Profile
dtaylor81
  • Answered Questions: 0
  • Posts: 7
  • Location:
  • Occupation:
No Profile
Following
User has not yet added friends.
Followers
User does not yet have followers.
My Tags
Rainsoft
My Recent Posts
 
Sat 5 Mar, 2011 01:40 pm - Soft water is great. It works now! (view)
Sat 26 Feb, 2011 03:10 pm - I tightened the tri-guard too tight and cracked it (STUPID - tighten slooooow and when it begins to get tight, turn only enough further to align the brine refill nuts). Purchased a used tri-guard,... (view)
Mon 21 Feb, 2011 07:55 pm - I removed the salt from the brine tank, cleaned the tank and the slotted tube. Removed the tri-guard and rinsed it out. Cleaned the poppit and replaced the o-ring. Replaced the brine injector... (view)
Sun 20 Feb, 2011 09:08 am - Pictures sent to your .gmail account. Thanks! (view)
Sat 19 Feb, 2011 04:52 pm - Does not appear to be cracked anywhere. Lines look OK and are tight. Poppet looks like it is centered and against the o-ring at the top of the tri-guard. I can send you pictures if you like. (view)
Sat 19 Feb, 2011 01:38 am - Yes sir, I replaced the o-rings on the brine injector when I repaired the stuck piston. (view)
Thu 17 Feb, 2011 05:00 pm - I have a Rainsoft Q2 system (Mod:AO24CT). I recently (6 mo. ago) replaced the valve o-rings, shut off tabs and shear pin after the valve siezed. It appeared to be working properly until about 3... (view)
 
  1. Forums
  2. » dtaylor81
Copyright © 2022 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.04 seconds on 05/17/2022 at 11:45:08