0
   

Rain Soft Brine Tank Overflow

 
 
Reply Sun 19 Dec, 2010 05:55 pm
My Rain Soft Gold Series water softener Brine Tank is not draining the water after it has been filled. The hose that runs from the bottom of the tank seems to get plugged, so I removed the tank from my garage and hauled it out to my driveway and emptied the salt from the tank. After it was empty, I took a hose and cleaned the tank completely and blew thru the hose to clear any particulate in the hose. I then filled the tank back up with the salt and hooked back up to the filter. It has worked fine for a few days or up to a week and then the same thing happens again. I have done this 3 times. I called Rain Soft and they told me it would cost me approx $175.00 for a visit and minor repairs. Does anyone have any idea what is causing this pain in my ass problem so I can save the money ?
  • Topic Stats
  • Top Replies
  • Link to this Topic
Type: Question • Score: 0 • Views: 1,592 • Replies: 2
No top replies

 
H2O MAN
 
  1  
Reply Sun 19 Dec, 2010 07:30 pm
@kscougar,
Check the rubber gasket where the brass fitting that holds the brine line attaches to the valve body.
There is also a small white plastic screen filter inside the brass fitting that can be cleaned.

0 Replies
 
Joethewaterguy
 
  1  
Reply Tue 21 Dec, 2010 10:00 pm
@kscougar,
Sounds like it's sucking air if it's overflowing. I'd replace the elbow that connects the brine line to the overflow control. Sometimes there is a screen shoved in this part too, that could be clogged but best bet is the elbow isn't sealing properly.
0 Replies
 
 

Related Topics

 
  1. Forums
  2. » Rain Soft Brine Tank Overflow
Copyright © 2014 MadLab, LLC :: Terms of Service :: Privacy Policy :: Page generated in 0.05 seconds on 09/02/2014 at 03:17:55